New Features "Login Device Tracking"
Incident Report for Synorex
Resolved
This incident has been resolved.
Posted Aug 11, 2021 - 14:39 GMT+08:00
Investigating
We are currently investigating this issue.
Posted Aug 11, 2021 - 11:36 GMT+08:00
This incident affected: Client Portal.